67 Beetle problems

  #1  
Old 03-27-2019, 04:26 PM
Junior Member
Thread Starter
Join Date: Mar 2019
Posts: 1
Default 67 Beetle problems

Hello all, new to this forum. I have a 67 beetle that every time I just turn the key on it smokes my distributor wires. Burnt up one electronic module in the distributor so I went back to points and condenser, because I had one laying around, hit the key and it burnt the wires going to the points. I have been driving this thing for 6 years. All I did was park it for the winter, 3 months, went to fire it up and this is the problem I'm having. Does anybody have any idea why this thing would be doing this? I would appreciate any and all suggestions, comments, help.
Thank you,
Ripcord.
 
  #2  
Old 03-30-2019, 09:47 AM
Keithuk's Avatar
Super Moderator
Join Date: Sep 2009
Location: Stoke on Trent, England
Posts: 2,213
Default

First posts normally go in introductions else you could get a free fix and we never see you again!!!

Default Welcome to Volkswagen Forum - Rules & Recommendations

A 1967 Beetle won't have electronic ignition that's been fitted since.

Check all wiring/connectors for a short circuit.

Please tell us your car spec in your signature
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
myjetta
Volkswagen Jetta/Bora
1
07-07-2011 10:23 AM
pillsberry1024
General Tech
2
03-23-2008 10:13 AM
nicolemarie2684
Volkswagen Beetle
2
09-18-2007 09:31 PM
Wintermute6
Volkswagen Beetle
2
09-25-2006 06:20 PM
clemsonscooby
Volkswagen Beetle
2
08-23-2006 08:49 AM


Thread Tools
Search this Thread
Quick Reply: 67 Beetle problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.