'04 Passat 1.8T.. so many issues.. sorry for the long post

  #1  
Old 08-26-2015, 01:23 AM
Junior Member
Thread Starter
Join Date: Aug 2015
Location: Small town in PA
Posts: 4
Angry '04 Passat 1.8T.. so many issues.. sorry for the long post


i apologize in advance. this is going to be an obnoxiously long post.

I have a 2004 VW Passat 1.8T with close to 140k miles on it...

1. when the cruise control is on and i hit the brake, the car speeds up. too dangerous to use.
2. head light lenses are oxidized on the inside. the lenses are one piece. and about $200 each.
3. my head lights themselves are worthless. you cant even tell that they're on. i rely on my day lamps at night. i've changed the bulbs and turns out that was not the problem.
4. fog lights don't come on at all.
5. engine light is on for the secondary air injection system. i've tried to learn how to check that system and there's so much involved in it i get confused.
6. my back door behind the driver doesn't open from the inside and sometimes doesn't unlock when i hit the button on the key fob to open it from the outside.
7. the hood hydraulic doesn't work. i prop my hood with a broken handle from a shovel.
8. the garage door button panel fell off of the visor. one of the little pin/hooks that clips it in place, broke.
9. the gear display on the dash, where it should highlight in red, the gear that you're currently in while driving and whatnot just highlights every gear. which i don't like while using the manual shift option.
10. there's oil leaking from somewhere, randomly. (i cant find where its leaking from) that problem seems to fix itself and go away for a while then all of a sudden come back.
11. hood release pull, that stupid little piece of plastic, broke. now i squeeze my hand in there and move the latch thing over and release the hood and bruise my hand every time.
12. driver window button/toggle broke. a little pin that pushes the button to make the window go up broke off of the window control and the little control/button/toggle whatever! thing almost got stuck in the hole where its supposed to be but wouldn't function.
13. license plate light is out. however that's just a bulb, most likely and hopefully.
14. the passenger side visor clip that holds the visor in place on the ceiling is broken.
15. lighter plug in the back seat doesn't work.
16. ash tray in the back seat falls out if you open it.
17. there's a hole in the floor in front of the driver seat.
18. coolant leak. its random like the oil leak. it will leak to the point where i have to fill it daily to avoid overheating then out of nowhere it just stops leaking for a while. (its weird)
19. transmission feels like its slipping sometimes but i've been told that could actually be a number of different things and not the trans (i don't have the $ it would cost to get the fluid level checked, considering it would be a waste of money if it wasn't the problem, since i cant check it myself due to this effin sealed engine! and he said he would have to keep my car for 2 days just to check the fluid) one person said i could be mistaking slipping trans for a malfunctioning turbo.
20. pretty sure someone blew a couple of my speakers. they're crackling. need new ones.
21. back brakes (i think that's where its coming from) make a loud high pitch noise but only in reverse. they scream.

any thoughts on ANY of these items would be appreciated!!! thank you in advance for your replies!

even if its a website suggestion for good parts cheaper. i usually go to auto zone for parts and they give me the wrong parts 90% of the time. i'm done with those fools!!

hope someone can help me
 
  #2  
Old 08-26-2015, 07:13 AM
Keithuk's Avatar
Super Moderator
Join Date: Sep 2009
Location: Stoke on Trent, England
Posts: 2,164
Default

You need to get your motor scanned (preferably with VAG-COM\VCDS) for any error codes logged in the ecu and post them, that will save a lot of guessing.

Please add your car spec to your signature?
 
  #3  
Old 08-26-2015, 07:44 AM
Junior Member
Thread Starter
Join Date: Aug 2015
Location: Small town in PA
Posts: 4
Default

Originally Posted by Keithuk View Post
You need to get your motor scanned (preferably with VAG-COM\VCDS) for any error codes logged in the ecu and post them, that will save a lot of guessing.

Please add your car spec to your signature?
do you mean like when the engine light is on? checking what codes it's throwing? I can't do that until I can get it running. only way I ever get the codes checked is bring it to auto zone.

my assumption of why it's not starting is the fuel pump or one of its components. im working on figuring it out 😏. I was told to check the fuse, wire harness, relays and filter before I go replacing the pump itself. so my bff, YouTube, is showing me where all of these parts are located in my car.

I'm kind of here to learn. be patient with me please. thanks for the reply!
 
  #4  
Old 08-26-2015, 07:29 PM
Keithuk's Avatar
Super Moderator
Join Date: Sep 2009
Location: Stoke on Trent, England
Posts: 2,164
Default

Well you can probably hear the fuel pump (in the fuel tank) prime for a second or two when you turn the ignition on.
 
  #5  
Old 08-26-2015, 07:49 PM
Junior Member
Thread Starter
Join Date: Aug 2015
Location: Small town in PA
Posts: 4
Default thanks

Originally Posted by Keithuk View Post
Well you can probably hear the fuel pump (in the fuel tank) prime for a second or two when you turn the ignition on.
I hear a click when I turn the key on. and I checked the fuse and the relay. Google taught me how to test a relay, today and the relay is good. the fuse looks good assuming the correct one is in that spot. double checking that now.. and then gotta educate myself on how to test the fuel pump wire harness. wires/electricity kind of scares me sometimes though.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
honestdave
PRIVATE For Sale / Trade Classifieds
0
05-16-2008 08:11 PM
pimemtel
Volkswagen Beetle
3
04-12-2008 07:10 PM
vw1.84motion
PRIVATE For Sale / Trade Classifieds
0
02-20-2008 11:53 AM
vw_smokescreen
New Member Area
0
11-19-2007 10:16 PM
tchristian
Volkswagen Jetta/Bora
0
09-12-2007 05:00 PM


Thread Tools
Search this Thread
Quick Reply: '04 Passat 1.8T.. so many issues.. sorry for the long post


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.