Volkswagen Jetta/Bora
Sponsored by:
Sponsored by:

Turbo Diesel Power Loss Problem

  #1  
Old 05-22-2007, 08:59 PM
Thread Starter
Join Date: May 2007
Posts: 3
Default Turbo Diesel Power Loss Problem

I have an 01 Jetta TDI 1.9. Have a loss of power now and then. Turn the power off and back on everything is good for a while. Engine check light comes on after this happens enough times. Have replaced the air mass flow sensor several times, problem keeps coming back. Many mechanics just want to keep trying things, way to expensive! One says around 160,000 miles the arm to wastegate can stick but you can only replace the whole turbo, way to expensive!! I found a website that sells an after market arm for $195.00 but still uncertain this is the problem solver. Anyone having the same problem with an answer please let me know. Thanks.
 
  #2  
Old 05-27-2007, 07:57 PM
Join Date: Apr 2007
Posts: 8
Default RE: Turbo Diesel Power Loss Problem

I had the same problem and it was the MAF, but apparently this does not seem to be yours since you have replaced it more than once. My suggestion is to go to "dieselgeek.com" it has some pretty sharp diesel gurus. They will show you how to check the turbo wastegate arm and free it. They may also give you some guidance on checking the vacuum lines to make sure that the arm is being energized.
 
  #3  
Old 05-27-2007, 08:26 PM
Join Date: Apr 2007
Posts: 8
Default RE: Turbo Diesel Power Loss Problem

Correction to my reply. The website to go to is "tdiclub.com" not "dieselgeek.com" Sorry about that.
 
  #4  
Old 05-29-2007, 10:44 AM
Join Date: Jan 2007
Posts: 25
Default RE: Turbo Diesel Power Loss Problem

Hey kvwgrindle,

Glad I checked in today - I had EXACTLY the same problem (even have the same car). After lots of diagnosis and guessing, it turns out it was a bad "boost sensor". Every now and then, I'd start up and have no boost (also, the check-engine light would go on). Turn it off and on again and I'd have boost. The sensor was going bad and re-starting the car essentially re-booted the computer.

The dealer replaced the boost sensor and rechecked all the connections. It's been fine ever since (hope I'm not jinxing myself - we thought I was going to have to replace the entire computer!!??!).

The check-engine light should give you a hint with the code, but it makes sense it's electronic (not mechanical) since it's going away with a re-boot. If your turbo works sometimes, my guess is it's fine.

To get it accurately diagnosed, I had to get it into the dealer WHILE the problem was happening. Maybe the same would be true for you.

Good Luck!
 
  #5  
Old 11-08-2011, 04:26 PM
Junior Member
Join Date: Apr 2008
Posts: 12
Default

KVWGRINDLE....I'm having a similar problem... I know this is an old post but I'm hoping you fixed your problem! I'll be driving and the power goes out...turn key off and back on...power is back. It happens every few minutes or even seconds sometime and it's driving me NUTS. It happens mostly on the highway but will happen elsewhere if I floor it. Was 'jettadriver' right? Did you ever figure it out?
If jettadriver reads this...how much was the sensor? and where is it?
Thanx!! Please let me know
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kyle4201605
Volkswagen Beetle
0
05-18-2008 03:59 PM
paultsutomugent
Volkswagen Golf
8
11-13-2007 08:40 PM
Andre
Other Volkswagen Models
0
04-24-2007 12:20 AM
baldy_54
Volkswagen GTi / TDi
1
04-22-2007 03:06 PM
paulv
Volkswagen Passat / CC
1
02-20-2007 07:45 PM


Thread Tools
Search this Thread
Quick Reply: Turbo Diesel Power Loss Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.