Emission Light Issue

  #1  
Old 10-25-2013, 09:33 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Location: Kissimmee, FL
Posts: 6
Default Emission Light Issue

I have had my 2006 Beetle for 2 weeks. The day I bought it, the Emission light came on. I was scared because earlier that day, it had been given the all clear by Firestone. The next day, I put premium fuel in, and drove it on the highway about 10 miles, to have the codes read. I got to Firestone, and turned the car off and on-the light was off. We figured that the car had been sitting (apart from test drives) and the fuel was old. So, tonight (2 weeks later) it came on again. So, I again put premium fuel in, and fuel additive (this was suggested after it went out the first time). I drove it a few miles (city driving, low speed) and it's still on. I made sure the gas cap is on tight. The only thing I can think of is my car had not been driven for 2 days as it was having the bumper fixed. The car runs great. Any thoughts???
 
  #2  
Old 10-28-2013, 06:31 PM
Junior Member
Join Date: Oct 2013
Location: Central Tennessee
Posts: 3
Default

Really wouldn't trust Firestone to be super knowledgeable about your Beetle......
I'd go to a VW specialist or a garage that specializes in European autos.....
It could be a number of things, Probably all minor if the car isn't missing and starts right up....Keeping track of your mileage would be a good indicator...If your in the mid to high twenties, Your OK...Anything lower....Really should be looked at by a VW specialist....If your air filter is really dirty it could be setting off the emission light by drawing to hard getting air to the throttle body......Good Luck!!!
 
  #3  
Old 11-05-2013, 04:36 PM
Keithuk's Avatar
Super Moderator
Join Date: Sep 2009
Location: Stoke on Trent, England
Posts: 2,213
Default

Welcome to the forum Jenni. Name:  VWwelcome.gif
Views: 142
Size:  951 Bytes

If the emission light is on then there should be an error code logged in the ecu, get it re-scanned.

https://volkswagenforum.com/forum/ne...gnature-34185/
 
  #4  
Old 11-08-2013, 08:53 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Location: Kissimmee, FL
Posts: 6
Question I swear my car is haunted!

Ok, so 2 weeks ago I posted the original message. Next day, drove my car (2006 Beetle) about 10 miles to have the codes read. Made 1 stop before, and the light went out. So, I was happy. Now, exactly 2 weeks later-in the same spot (on the same road) and at the same time of day, it comes on again! The only other thing I can think of, all 3 times right before it came on, I was sitting in my car for about 45 minutes with the engine off. The first 2 times I had the key in, and this time I took it out. But the same thing happens! I am so confused. So, I am planning on going to have the codes read tomorrow. BUT, here's another issue-I replaced the stereo 3 weeks ago. It was professionally installed, and it's a Sony radio. Will this cause an issue with reading the codes?
 
  #5  
Old 11-09-2013, 09:33 AM
Keithuk's Avatar
Super Moderator
Join Date: Sep 2009
Location: Stoke on Trent, England
Posts: 2,213
Default

Don't use that road.

If the results read by the ecu from the sensors come within tolerance the light may go out for a while but it will still be logged in the ecu, faults don't cure themselves.

I believe AutoZone will do a free scan in the hope you buy something off them.

https://volkswagenforum.com/forum/ne...gnature-34185/
 
  #6  
Old 11-19-2013, 01:34 PM
Member
Join Date: Aug 2013
Posts: 40
Default

Autozone scans for free, you can also disconnect the battery and see if it goes away.
 
  #7  
Old 11-27-2013, 03:12 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Location: Kissimmee, FL
Posts: 6
Default Update!

So, I again headed to have the car scanned. Light goes out! I then ordered my own OBD II scanner on ebay. Got a great deal. Exactly 2 weeks again goes by, same time and day and it the light comes on again! I plug the scanner in, and read the engine….NO ERROR CODES! LOL! I scanned it a few times. Turned the car on, and the light was out. The scanner I got was a special one for VW's and Audi's. I have scanned it a few times since (without the light on) and it still reads no error codes.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vr6passat
Volkswagen Passat / CC
0
01-05-2010 07:05 PM
kaylynn
Volkswagen Jetta/Bora
2
05-30-2009 11:01 AM
freeholtz08
Volkswagen Passat / CC
1
12-23-2008 08:04 PM
vwbmx
Volkswagen Golf
1
05-23-2008 02:52 PM
pablocruz69
Volkswagen Jetta/Bora
2
02-10-2007 02:53 AM


Thread Tools
Search this Thread
Quick Reply: Emission Light Issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.